NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2025-1302 — jsonpath-plus

Fix: JSONPath-Plus/JSONPath@3094289

CVE-2025-1302 is a Code Injection vulnerability in jsonpath-plus. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for jsonpath-plus — see the affected versions and patch details below.

JSONPath Plus allows Remote Code Execution

Also known asGHSA-hw8r-x6gr-5gjp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-1302.

EPSS Exploitation Probability

via FIRST.org ↗
10.4%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%89.9%10.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
jsonpath-plusnpm
17.1Mdownloads / week

Description

Versions of the package jsonpath-plus before 10.3.0 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of eval='safe' mode.

Note:

This is caused by an incomplete fix for CVE-2024-21534.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmjsonpath-plusall versions10.3.0npm install jsonpath-plus@10.3.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jsonpath-plus, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update jsonpath-plus to 10.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-1302 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

How to detect CVE-2025-1302

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2025-1302 -u https://target
Template
JSONPath Plus < 10.3.0 - Remote Code Execution
Severity
critical
Impact
Attackers can execute arbitrary code on the system, potentially leading to full system compromise.
Remediation
Update to version 10.3.0 or later.

Template by ProjectDiscovery nuclei-templates (Jaenact), MIT licensed. View the full template. Scan only systems you are authorised to test.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

Red Hat's initial impact rating of critical has been downgraded to low. While the vulnerable code is technically still present within Red Hat products, there are no code paths in affected products which allow exploitation. As such, the impact to Red Hat products is low. Each of the products listed have multiple…

Workaround published by Red Hat
Red Hat Product Security recommends updating the vulnerable software to the latest version.
Source: Red Hat security advisory for CVE-2025-1302 (CC BY 4.0)

Frequently Asked Questions

Versions of the package jsonpath-plus before 10.3.0 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of eval='safe' mode. **Note:** This is caused by an incomplete fix for [CVE-2024-21534](https://security.snyk.io/vuln/SNYK-JS-JSONPATHPLUS-7945884).
O3 Security · Impact-Aware SCA

Is CVE-2025-1302 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2025-1302: jsonpath-plus RCE — Fixed in 10.3.0