NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2024-21534 — jsonpath-plus

CRITICALFix: JSONPath-Plus/JSONPath#233

CVE-2024-21534 is a critical-severity (CVSS 9.8) Code Injection vulnerability in org.webjars.npm:jsonpath-plus. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.webjars.npm:jsonpath-plus — see the affected versions and patch details below.

JSONPath Plus Remote Code Execution (RCE) Vulnerability

Published
Updated
Affected
2 pkgs
Patched
1 / 2
Exploits
3 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-21534.

EPSS Exploitation Probability

via FIRST.org ↗
9.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%92.7%9.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
jsonpath-plusnpm
16.9Mdownloads / week

Description

Versions of the package jsonpath-plus before 10.0.7 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of vm in Node.

Note:

There were several attempts to fix it in versions 10.0.0-10.1.0 but it could still be exploited using different payloads

Affected Packages

2 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.webjars.npm:jsonpath-plusall versionsNo fix
📦npmjsonpath-plusall versions10.2.0npm install jsonpath-plus@10.2.0
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars.npm:jsonpath-plus, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2024-21534; check the affected-versions list above or the advisory for the patched release of org.webjars.npm:jsonpath-plus, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

Red Hat's initial impact rating of critical has been downgraded to low. While the vulnerable code is technically still present within Red Hat products, there are no code paths in affected products which allow exploitation. As such, the impact to Red Hat products is low. Each of the products listed have multiple…

Workaround published by Red Hat
Red Hat Product Security recommends updating the vulnerable software to the latest version.
Source: Red Hat security advisory for CVE-2024-21534 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat OpenShift Dev Spaces 3 Containersdevspaces/code-rhel8:3.17-19RHSA-2024:10236
Red Hat Developer Hub 1.6rhdh/rhdh-hub-rhel9:1.6.0-1745956724RHSA-2025:7626

Frequently Asked Questions

Versions of the package jsonpath-plus before 10.0.7 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of vm in Node. **Note:** There were several attempts to fix it in versions [10.0.0-10.1.0](https://github.com/JSONPath-Plus/JSONPath/compare/v9.0.0...v10.1.0) but it could still be exploited using [different payloads](https://github.com/JSONPath-Plus/JSONPath/issues/226)
O3 Security · Impact-Aware SCA

Is CVE-2024-21534 in your dependencies?

Find it across Maven, npm, including transitive dependencies.

CVE-2024-21534: jsonpath-plus RCE — Fixed in 10.2.0