CVE-2025-12760 — email_tfa
MEDIUMCVE-2025-12760 is a medium-severity (CVSS 5.4) CWE-288 vulnerability in drupal/email_tfa. A fix is available for drupal/email_tfa — see the affected versions and patch details below.
Email TFA - Moderately critical - Access bypass - SA-CONTRIB-2025-115
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-12760.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/email_tfaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Authentication Bypass Using an Alternate Path or Channel vulnerability in Drupal Email TFA allows Functionality Bypass. This issue affects Email TFA: from 0.0.0 before 2.0.6.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/email_tfa | all versions | 2.0.6composer require drupal/email_tfa:^2.0.6 |
Affected Products
email tfaemail_tfa_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/email_tfa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/email_tfa to 2.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-12760 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-12760 in your dependencies?
Find it across Packagist, including transitive dependencies.