NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 Packagist:https://packages.drupal.org/8
Not in CISA KEV

CVE-2025-10930 — currency

CVE-2025-10930 is a Cross-Site Request Forgery (CSRF) vulnerability in drupal/currency. A fix is available for drupal/currency — see the affected versions and patch details below.

Also known asGHSA-27fv-rpgj-4c6m
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-10930.

EPSS Exploitation Probability

via FIRST.org ↗
0.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs3th percentile — riskier than 3% of all scored CVEsHighest risk
0.00%0.21%0.42%0.63%0.0%0.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
📦drupal/currency

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist:https://packages.drupal.org/8 packages — download data is not available via public APIs for these ecosystems.

Description

This module allows you to use different currencies on your website and do currency conversion.

The module doesn't sufficiently protect routes used to enable and disable currencies from Cross-Site Request Forgery (CSRF) attacks, potentially allowing an attacker to trick an admin into changing settings.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦Packagist:https://packages.drupal.org/8drupal/currencyall versions3.5.0

Affected Products

1 product · 1 configurations
Application
currency2bits
< 8.x-3.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/currency, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/currency to 3.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-10930 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

This module allows you to use different currencies on your website and do currency conversion. The module doesn't sufficiently protect routes used to enable and disable currencies from Cross-Site Request Forgery (CSRF) attacks, potentially allowing an attacker to trick an admin into changing settings.
O3 Security · Impact-Aware SCA

Is CVE-2025-10930 in your dependencies?

Find it across Packagist:https://packages.drupal.org/8, including transitive dependencies.

CVE-2025-10930: currency CSRF — Fixed in 3.5.0