NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 Packagist:https://packages.drupal.org/8
Not in CISA KEV

CVE-2025-10926 — json_field

CVE-2025-10926 is a Cross-site Scripting (XSS) vulnerability in drupal/json_field. A fix is available for drupal/json_field — see the affected versions and patch details below.

Also known asGHSA-m3f2-xjgc-2wp2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-10926.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs10th percentile — riskier than 10% of all scored CVEsHighest risk
0.00%0.23%0.47%0.70%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
📦drupal/json_field

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist:https://packages.drupal.org/8 packages — download data is not available via public APIs for these ecosystems.

Description

This module enables you to store and display JSON data using optional 3rd party libraries.

The module doesn't sufficiently filter data using some of the included field formatters leading to a Cross-site Scripting (XSS) vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦Packagist:https://packages.drupal.org/8drupal/json_fieldall versions1.5.0

Affected Products

1 product · 1 configurations
Application
json fieldjson_field_project
< 8.x-1.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/json_field, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/json_field to 1.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-10926 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

This module enables you to store and display JSON data using optional 3rd party libraries. The module doesn't sufficiently filter data using some of the included field formatters leading to a Cross-site Scripting (XSS) vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2025-10926 in your dependencies?

Find it across Packagist:https://packages.drupal.org/8, including transitive dependencies.

CVE-2025-10926: json_field XSS — Fixed in 1.5.0