NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2024-7340 — weave

HIGHFix: wandb/weave#1657

CVE-2024-7340 is a high-severity (CVSS 8.8) Path Traversal vulnerability in weave. A fix is available for weave — see the affected versions and patch details below.

W&B Weave server remote arbitrary file leak and privilege escalation

Also known asGHSA-r49h-6qxq-624fPYSEC-2026-2035
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-7340.

EPSS Exploitation Probability

via FIRST.org ↗
5.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%87.7%5.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍weave

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The Weave server API allows remote users to fetch files from a specific directory, but due to a lack of input validation, it is possible to traverse and leak arbitrary files remotely. In various common scenarios, this allows a low-privileged user to assume the role of the server admin.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIweaveall versions0.50.8pip install --upgrade 'weave==0.50.8'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for weave, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update weave to 0.50.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-7340 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

How to detect CVE-2024-7340

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2024-7340 -u https://target
Template
W&B Weave Server - Remote Arbitrary File Leak
Severity
high
Impact
Authenticated low-privileged attackers can exploit path traversal to read arbitrary files from the server, potentially accessing sensitive configuration files and credentials to escalate privileges to admin level.
Remediation
Update W&B Weave Server to a version that includes the fix from pull request #1657 addressing the path traversal vulnerability.

Template by ProjectDiscovery nuclei-templates (iamnoooob, rootxharsh, pdresearch), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

The Weave server API allows remote users to fetch files from a specific directory, but due to a lack of input validation, it is possible to traverse and leak arbitrary files remotely. In various common scenarios, this allows a low-privileged user to assume the role of the server admin.
O3 Security · Impact-Aware SCA

Is CVE-2024-7340 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-7340: weave — Fixed in 0.50.8