CVE-2024-6827 is a high-severity (CVSS 7.5) CWE-444 vulnerability in gunicorn. A fix is available for gunicorn — see the affected versions and patch details below.
Gunicorn HTTP Request/Response Smuggling vulnerability
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-6827.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
gunicornReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Gunicorn version 21.2.0 does not properly validate the value of the 'Transfer-Encoding' header as specified in the RFC standards, which leads to the default fallback method of 'Content-Length,' making it vulnerable to TE.CL request smuggling. This vulnerability can lead to cache poisoning, data exposure, session manipulation, SSRF, XSS, DoS, data integrity compromise, security bypass, information leakage, and business logic abuse.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | gunicorn | all versions | 22.0.0pip install --upgrade 'gunicorn==22.0.0' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for gunicorn, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update gunicorn to 22.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-6827 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Product Security currently does not have a recommended mitigation at this time.Source: Red Hat security advisory for CVE-2024-6827 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Discovery 1 for RHEL 9 | discovery/discovery-server-rhel9:1.13.1-1 | RHSA-2025:3709 |
| Red Hat Quay 3 | quay/clair-rhel8:v3.9.11-5 | RHBA-2025:3538 |
| Red Hat Quay 3 | quay/clair-rhel8:v3.13.5-4 | RHBA-2025:3651 |
| Red Hat Quay 3 | quay/clair-rhel8:v3.12.9-3 | RHBA-2025:3652 |
| Red Hat Quay 3 | quay/clair-rhel8:v3.11.10-3 | RHBA-2025:3653 |
| Red Hat Quay 3 | quay/clair-rhel8:v3.10.10-4 | RHBA-2025:4023 |
Frequently Asked Questions
Is CVE-2024-6827 in your dependencies?
Find it across PyPI, including transitive dependencies.