NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2018-1000164 — gunicorn

HIGHFix: benoitc/gunicorn@1e10a02

CVE-2018-1000164 is a high-severity (CVSS 7.5) CWE-93 vulnerability in gunicorn. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for gunicorn — see the affected versions and patch details below.

Gunicorn contains Improper Neutralization of CRLF sequences in HTTP headers

Also known asGHSA-32pc-xphx-q4f6PYSEC-2018-55
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.98%1.64%2.30%2.95%1.5%2.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍gunicorn

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIgunicornall versions19.5.0pip install --upgrade 'gunicorn==19.5.0'

Affected Products

2 products · 3 configurations
OS
debian linuxdebian
2 versions
7.08.0
Application
gunicorngunicorn
1 version
19.4.5
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for gunicorn, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update gunicorn to 19.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000164 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.
O3 Security · Impact-Aware SCA

Is CVE-2018-1000164 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2018-1000164: gunicorn — Fixed in 19.5.0