NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2024-6376 — @mongodb-js/connection-fo…

HIGHFix: mongodb-js/compass@b1f8050

CVE-2024-6376 is a high-severity (CVSS 7) Improper Input Validation vulnerability in @mongodb-js/connection-form. A fix is available for @mongodb-js/connection-form — see the affected versions and patch details below.

ejson shell parser in MongoDB Compass maybe bypassed

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 18, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-6376.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs40th percentile — riskier than 40% of all scored CVEsHighest risk
0.00%0.39%0.77%1.16%0.5%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

3other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@mongodb-js/connection-formnpm
136downloads / week

Description

MongoDB Compass may be susceptible to code injection due to insufficient sandbox protection settings with the usage of ejson shell parser in Compass' connection handling. This issue affects MongoDB Compass versions prior to version 1.42.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@mongodb-js/connection-formall versions1.20.1npm install @mongodb-js/connection-form@1.20.1

Affected Products

1 product · 1 configurations
Application
compassmongodb
< 1.42.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @mongodb-js/connection-form, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @mongodb-js/connection-form to 1.20.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-6376 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

MongoDB Compass may be susceptible to code injection due to insufficient sandbox protection settings with the usage of ejson shell parser in Compass' connection handling. This issue affects MongoDB Compass versions prior to version 1.42.2.
O3 Security · Impact-Aware SCA

Is CVE-2024-6376 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-6376: @mongodb-js/connection — Fixed in 1.20.1