NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-5658 — craft-twofactorauthentica…

MEDIUMFix: born05/craft-twofactorauthentication@89d2339

CVE-2024-5658 is a medium-severity (CVSS 4.8) CWE-303 vulnerability in born05/craft-twofactorauthentication. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for born05/craft-twofactorauthentication — see the affected versions and patch details below.

CraftCMS Plugin - Two-Factor Authentication - TOTP Token Stays Valid After Use

Also known asGHSA-96qm-hwhp-2rm8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-5658.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs48th percentile — riskier than 48% of all scored CVEsHighest risk
0.00%0.36%0.73%1.09%0.2%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘born05/craft-twofactorauthentication

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The CraftCMS plugin Two-Factor Authentication through 3.3.3 allows reuse of TOTP tokens multiple times within the validity period.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistborn05/craft-twofactorauthenticationall versions3.3.4composer require born05/craft-twofactorauthentication:^3.3.4

Affected Products

1 product · 1 configurations
Application
two-factor authenticationborn05
< 3.3.4
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for born05/craft-twofactorauthentication, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update born05/craft-twofactorauthentication to 3.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-5658 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

The CraftCMS plugin Two-Factor Authentication through 3.3.3 allows reuse of TOTP tokens multiple times within the validity period.
O3 Security · Impact-Aware SCA

Is CVE-2024-5658 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-5658: craft-twofactorauthentica… — Fixed in 3.3.4