NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
LOW severity

CVE-2024-5657 — craft-twofactorauthentica…

LOWFix: born05/craft-twofactorauthentication@eb93bcb

CVE-2024-5657 is a low-severity (CVSS 3.7) CWE-499 vulnerability in born05/craft-twofactorauthentication. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for born05/craft-twofactorauthentication — see the affected versions and patch details below.

CraftCMS Plugin - Two-Factor Authentication - Password Hash Disclosure

Also known asGHSA-3p4x-grpm-xw58
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-5657.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.44%0.89%1.33%0.2%0.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘born05/craft-twofactorauthentication

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The CraftCMS plugin Two-Factor Authentication in versions 3.3.1, 3.3.2 and 3.3.3 discloses the password hash of the currently authenticated user after submitting a valid TOTP.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistborn05/craft-twofactorauthentication≥ 3.3.1&&< 3.3.43.3.4composer require born05/craft-twofactorauthentication:^3.3.4

Affected Products

1 product · 1 configurations
Application
two-factor authenticationborn05
≥ 3.3.1 && < 3.3.4
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for born05/craft-twofactorauthentication, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update born05/craft-twofactorauthentication to 3.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-5657 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The CraftCMS plugin Two-Factor Authentication in versions 3.3.1, 3.3.2 and 3.3.3 discloses the password hash of the currently authenticated user after submitting a valid TOTP.
O3 Security · Impact-Aware SCA

Is CVE-2024-5657 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-5657: craft-twofactorauthentica… — Fixed in 3.3.4