NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2024-56509 — changedetection-io

HIGHFix: dgtlmoon/changedetection.io@f7e9846

CVE-2024-56509 is a high-severity (CVSS 8.6) Path Traversal vulnerability in changedetection-io. A fix is available for changedetection-io — see the affected versions and patch details below.

changedetection.io has Improper Input Validation Leading to LFR/Path Traversal

Also known asGHSA-j5vv-6wjg-cfr8PYSEC-2026-1242
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-56509.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.81%1.22%0.1%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍changedetection-io

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Summary

Improper input validation in the application can allow attackers to perform local file read (LFR) or path traversal attacks. These vulnerabilities occur when user input is used to construct file paths without adequate sanitization or validation. For example, using file:../../../etc/passwd or file: ///etc/passwd can bypass weak validations and allow unauthorized access to sensitive files. Even though this has been addressed in previous patch, it is still insufficient.

Details

The check in this line of code is insufficient.

if re.search(r'^file:/', url.strip(), re.IGNORECASE):

The attacker can still bypass this by using: -file:../../../../etc/passwd -file: ///etc/passwd (with space before /)

PoC

  • Open up a changedetection.io instance with a webdriver configured.
  • Create a new watch with file:../../../../etc/passwd.
  • Check the watch preview.
  • The contents of /etc/passwd should pop out.

Screenshots

image image

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIchangedetection-ioall versions0.48.05pip install --upgrade 'changedetection-io==0.48.05'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for changedetection-io, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update changedetection-io to 0.48.05 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-56509 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

### Summary Improper input validation in the application can allow attackers to perform local file read (LFR) or path traversal attacks. These vulnerabilities occur when user input is used to construct file paths without adequate sanitization or validation. For example, using `file:../../../etc/passwd` or `file: ///etc/passwd` can bypass weak validations and allow unauthorized access to sensitive files. Even though this has been addressed in previous patch, it is still insufficient. ### Details The check in this line of code is insufficient. ``` if re.search(r'^file:/', url.strip(), re.IGNORE
O3 Security · Impact-Aware SCA

Is CVE-2024-56509 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-56509: changedetection — Fixed in 0.48.05