NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-55893 — cms-belog

MEDIUMFix: TYPO3-CMS/belog@0eb171f

CVE-2024-55893 is a medium-severity (CVSS 4.3) Cross-Site Request Forgery (CSRF) vulnerability in typo3/cms-belog. A fix is available for typo3/cms-belog — see the affected versions and patch details below.

TYPO3 Cross-Site Request Forgery in Log Module

Also known asGHSA-cjfr-9f5r-3q93
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-55893.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs17th percentile — riskier than 17% of all scored CVEsHighest risk
0.00%0.36%0.72%1.08%0.6%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘typo3/cms-belog🐘typo3/cms-belog🐘typo3/cms-belog🐘typo3/cms-belog

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Problem

A vulnerability has been identified in the backend user interface functionality involving deep links. Specifically, this functionality is susceptible to Cross-Site Request Forgery (CSRF). Additionally, state-changing actions in downstream components incorrectly accepted submissions via HTTP GET and did not enforce the appropriate HTTP method.

Successful exploitation of this vulnerability requires the victim to have an active session on the backend user interface and to be deceived into interacting with a malicious URL targeting the backend, which can occur under the following conditions:

  • the user opens a malicious link, such as one sent via email.
  • the user visits a compromised or manipulated website while the following settings are misconfigured:
    • security.backend.enforceReferrer feature is disabled,
    • BE/cookieSameSite configuration is set to lax or none

The vulnerability in the affected downstream component “Log Module” allows attackers to remove log entries.

Solution

Update to TYPO3 versions 11.5.42 ELTS, 12.4.25 LTS, 13.4.3 LTS that fix the problem described.

Credits

Thanks to Gabriel Dimitrov who reported this issue and to TYPO3 core and security members Benjamin Franzke, Oliver Hader, Andreas Kienast, Torben Hansen, Elias Häußler who fixed the issue.

References

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-belog≥ 10.0.0&&< 10.4.4810.4.48composer require typo3/cms-belog:^10.4.48
🐘Packagisttypo3/cms-belog≥ 11.0.0&&< 11.5.4211.5.42composer require typo3/cms-belog:^11.5.42
🐘Packagisttypo3/cms-belog≥ 12.0.0&&< 12.4.2512.4.25composer require typo3/cms-belog:^12.4.25
🐘Packagisttypo3/cms-belog≥ 13.0.0&&< 13.4.313.4.3composer require typo3/cms-belog:^13.4.3

Affected Products

1 product · 4 configurations
Application
typo3typo3
≥ 13.0.0 && < 13.4.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-belog, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-belog to 10.4.48 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-55893 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Problem A vulnerability has been identified in the backend user interface functionality involving deep links. Specifically, this functionality is susceptible to Cross-Site Request Forgery (CSRF). Additionally, state-changing actions in downstream components incorrectly accepted submissions via HTTP GET and did not enforce the appropriate HTTP method. Successful exploitation of this vulnerability requires the victim to have an active session on the backend user interface and to be deceived into interacting with a malicious URL targeting the backend, which can occur under the following cond
O3 Security · Impact-Aware SCA

Is CVE-2024-55893 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-55893: cms-belog CSRF — Fixed in 10.4.48