NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2024-54003 — simple-queue

HIGH

CVE-2024-54003 is a high-severity (CVSS 8) Cross-site Scripting (XSS) vulnerability in io.jenkins.plugins:simple-queue. EPSS puts its 30-day exploitation probability at 81.2% (100th percentile). A fix is available for io.jenkins.plugins:simple-queue — see the affected versions and patch details below.

Jenkins Simple Queue Plugin has stored cross-site scripting (XSS) vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-54003.

EPSS Exploitation Probability

via FIRST.org ↗
81.2%probability of exploitation in next 30 days
Very High Risk+1.10%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
76.3%78.3%80.3%82.3%77.5%80.1%81.2%Jul 26Nov 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕io.jenkins.plugins:simple-queue

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Simple Queue Plugin 1.4.4 and earlier does not escape the view name.

This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with View/Create permission.

Simple Queue Plugin 1.4.5 escapes the view name.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.jenkins.plugins:simple-queueall versions1.4.5io.jenkins.plugins:simple-queue:1.4.5

Affected Products

1 product · 1 configurations
Application
simple queuejenkins
≤ 1.4.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.jenkins.plugins:simple-queue, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.jenkins.plugins:simple-queue to 1.4.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-54003 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Jenkins Simple Queue Plugin 1.4.4 and earlier does not escape the view name. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with View/Create permission. Simple Queue Plugin 1.4.5 escapes the view name.
O3 Security · Impact-Aware SCA

Is CVE-2024-54003 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2024-54003: simple-queue XSS — Fixed in 1.4.5