NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2024-53382 — prismjs

MEDIUMFix: PrismJS/prism#3863

CVE-2024-53382 is a medium-severity (CVSS 4.9) Code Injection vulnerability in prismjs. A fix is available for prismjs — see the affected versions and patch details below.

PrismJS DOM Clobbering vulnerability

Also known asGHSA-x7hr-w5r2-h6wg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-53382.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs26th percentile — riskier than 26% of all scored CVEsHighest risk
0.00%0.28%0.56%0.84%0.1%0.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

5Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
prismjsnpm
21.3Mdownloads / week

Description

Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmprismjsall versions1.30.0npm install prismjs@1.30.0

Affected Products

1 product · 1 configurations
Application
prismprismjs
≤ 1.29.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for prismjs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update prismjs to 1.30.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-53382 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Ceph Storage 7.1rhceph/grafana-rhel10:11.6.2-7RHSA-2025:11889
Red Hat Ceph Storage 8.1rhceph/grafana-rhel9:11.6.2-4RHSA-2025:11749
Red Hat Developer Hub 1.9rhdh/rhdh-hub-rhel9:1772573159RHSA-2026:3751

Frequently Asked Questions

Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.
O3 Security · Impact-Aware SCA

Is CVE-2024-53382 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-53382: prismjs XSS — Fixed in 1.30.0