NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 GitHub Actions
Not in CISA KEV

CVE-2024-52587 — harden-runner

Fix: step-security/harden-runner@0080882

CVE-2024-52587 is a OS Command Injection vulnerability in step-security/harden-runner. A fix is available for step-security/harden-runner — see the affected versions and patch details below.

Harden-Runner has command injection weaknesses in `setup.ts` and `arc-runner.ts`

Also known asGHSA-g85v-wf27-67xc
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-52587.

EPSS Exploitation Probability

via FIRST.org ↗
2.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
1.50%2.09%2.68%3.26%2.0%2.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
📦step-security/harden-runner

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects GitHub Actions packages — download data is not available via public APIs for these ecosystems.

Description

Summary

Versions of step-security/harden-runner prior to v2.10.2 contain multiple command injection weaknesses via environment variables that could potentially be exploited under specific conditions. However, due to the current execution order of pre-steps in GitHub Actions and the placement of harden-runner as the first step in a job, the likelihood of exploitation is low as the Harden-Runner action reads the environment variable during the pre-step stage. There are no known exploits at this time.

Details

  1. setup.ts:169 1 performs execSync with a command that gets invoked after interpretation by the shell. This command includes an interpolated process.env.USER variable, which an attacker could modify (without actually creating a new user) to inject arbitrary shell expressions into this execSync. This may or may not be likely in practice, but I believe the hygienic way to perform the underlying operation is to use execFileSync or similar and bypass the underlying shell evaluation.

  2. setup.ts:229 2 has a nearly identical execSync to (1) above, but with $USER for shell-level interpolation rather than string interpolation. However, this is still injectable and would be best replaced by an execFileSync, per above.

  3. arc-runner:40-44 3 has an execSync with multiple string interpolations. Most of these do not appear immediately injectible (since they appear to come from presumed trusted API responses), but the expansion of getRunnerTempDir() may be injectable due to its dependence on potentially attacker-controllable environment variables (e.g. RUNNER_TEMP). The underlying operation appears to be a trivial file copy, so this entire subprocess should in theory be replaceable with ordinary NodeJS fs API calls instead.

  4. arc-runner:53 4 demonstrates the same weakness, and has the same resolution as (3).

  5. arc-runner:57 demonstrates the same weakness as (3) and (4), and has the same resolution.

  6. arc-runner:61 demonstrates the same weakness as (3), (4), and (5), and has the same resolution.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦GitHub Actionsstep-security/harden-runnerall versions2.10.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for step-security/harden-runner, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update step-security/harden-runner to 2.10.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-52587 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

### Summary Versions of step-security/harden-runner prior to v2.10.2 contain multiple command injection weaknesses via environment variables that could potentially be exploited under specific conditions. However, due to the current execution order of pre-steps in GitHub Actions and the placement of harden-runner as the first step in a job, the likelihood of exploitation is low as the Harden-Runner action reads the environment variable during the pre-step stage. There are no known exploits at this time. ### Details 1. setup.ts:169 [1] performs `execSync` with a command that gets invoked af
O3 Security · Impact-Aware SCA

Is CVE-2024-52587 in your dependencies?

Find it across GitHub Actions, including transitive dependencies.

CVE-2024-52587: harden-runner — Fixed in 2.10.2