CVE-2024-50340 is a high-severity (CVSS 7.3) CWE-74 vulnerability in symfony/runtime. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for symfony/runtime — see the affected versions and patch details below.
Ability to change environment from query in symfony/runtime
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-50340.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/runtime🐘symfony/runtime🐘symfony/runtime🐘symfony/symfony🐘symfony/symfony🐘symfony/symfonyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
symfony/runtime is a module for the Symphony PHP framework which enables decoupling PHP applications from global state. When the register_argv_argc php directive is set to on , and users call any URL with a special crafted query string, they are able to change the environment or debug mode used by the kernel when handling the request. As of versions 5.4.46, 6.4.14, and 7.1.7 the SymfonyRuntime now ignores the argv values for non-SAPI PHP runtimes. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/runtime | ≥ 5.3.0&&< 5.4.46 | 5.4.46composer require symfony/runtime:^5.4.46 |
| 🐘Packagist | symfony/runtime | ≥ 6.0.0&&< 6.4.14 | 6.4.14composer require symfony/runtime:^6.4.14 |
| 🐘Packagist | symfony/runtime | ≥ 7.0.0&&< 7.1.7 | 7.1.7composer require symfony/runtime:^7.1.7 |
| 🐘Packagist | symfony/symfony | ≥ 5.3.0&&< 5.4.46 | 5.4.46composer require symfony/symfony:^5.4.46 |
| 🐘Packagist | symfony/symfony | ≥ 6.0.0&&< 6.4.14 | 6.4.14composer require symfony/symfony:^6.4.14 |
| 🐘Packagist | symfony/symfony | ≥ 7.0.0&&< 7.1.7 | 7.1.7composer require symfony/symfony:^7.1.7 |
Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/runtime, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/runtime to 5.4.46 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-50340 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
How to detect CVE-2024-50340
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2024-50340 -u https://target- Template
- Symfony Profiler - Remote Access via Injected Arguments
- Severity
- high
- Impact
- Attackers can exploit vulnerabilities to compromise the system.
- Remediation
- Update to the latest patched version addressing CVE-2024-50340.
Template by ProjectDiscovery nuclei-templates (DhiyaneshDK), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2024-50340 in your dependencies?
Find it across Packagist, including transitive dependencies.