CVE-2024-48929 — Umbraco.CMS
MEDIUMCVE-2024-48929 is a medium-severity (CVSS 4.2) CWE-384 vulnerability in Umbraco.CMS. A fix is available for Umbraco.CMS — see the affected versions and patch details below.
Umbraco CMS Has Incomplete Server Termination During Explicit Sign-Out
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-48929.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Umbraco.CMS.NETUmbraco.CMSReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
Umbraco is a free and open source .NET content management system. In versions on the 13.x branch prior to 13.5.2 and versions on the 10.x branch prior to 10.8.7, during an explicit sign-out, the server session is not fully terminated. Versions 13.5.2 and 10.8.7 contain a patch for the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Umbraco.CMS | ≥ 13.0.0&&< 13.5.2 | 13.5.2dotnet add package Umbraco.CMS --version 13.5.2 |
| .NETNuGet | Umbraco.CMS | ≥ 10.0.0&&< 10.8.7 | 10.8.7dotnet add package Umbraco.CMS --version 10.8.7 |
Affected Products
umbraco cmsumbracoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Umbraco.CMS, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Umbraco.CMS to 13.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-48929 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-48929 in your dependencies?
Find it across NuGet, including transitive dependencies.