CVE-2023-49273 — Umbraco.CMS
MEDIUMCVE-2023-49273 is a medium-severity (CVSS 5.4) CWE-863 vulnerability in Umbraco.CMS. A fix is available for Umbraco.CMS — see the affected versions and patch details below.
Umbraco CMS vulnerable to Privilege Escalation using Spoofing
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Umbraco.CMS.NETUmbraco.CMS.NETUmbraco.CMSReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Users with low privileges ( Editor, etc) are able to access some unintended endpoints.
Explanation of the vulnerability
Possible to delete redirect urls, when disabled by admin with only access to backoffice Possible to access the examine dashboard with only access to backoffice Possible to access the published cache dashboard with only access to backoffice Possible to access the telemetry dashboard with only access to backoffice Possible to access the languages with only access to backoffice Possible to access the stylesheets with only access to backoffice
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Umbraco.CMS | ≥ 8.0.0&&< 8.18.10 | 8.18.10dotnet add package Umbraco.CMS --version 8.18.10 |
| .NETNuGet | Umbraco.CMS | ≥ 9.0.0&&< 10.8.1 | 10.8.1dotnet add package Umbraco.CMS --version 10.8.1 |
| .NETNuGet | Umbraco.CMS | ≥ 11.0.0&&< 12.3.4 | 12.3.4dotnet add package Umbraco.CMS --version 12.3.4 |
Affected Products
umbraco cmsumbracoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Umbraco.CMS, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Umbraco.CMS to 8.18.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-49273 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2023-49273 in your dependencies?
Find it across NuGet, including transitive dependencies.