CVE-2024-48914 is a critical-severity (CVSS 9.1) Improper Input Validation vulnerability in @vendure/asset-server-plugin. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for @vendure/asset-server-plugin — see the affected versions and patch details below.
Vendure asset server plugin has local file read vulnerability with AssetServerPlugin & LocalAssetStorageStrategy
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-48914.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@vendure/asset-server-pluginnpmDescription
Description
Path traversal
This vulnerability allows an attacker to craft a request which is able to traverse the server file system and retrieve the contents of arbitrary files, including sensitive data such as configuration files, environment variables, and other critical data stored on the server.
From Rajesh Sharma who discovered the vulnerability:
POC: curl --path-as-is http://localhost:3000/assets/../package.json gives you the content of package.json present in the local directory.
The vulnerability stems from usage of decodedReqPath directly in path.join without performing any path normalization i.e path.normalize in node.js
If the vendure service is behind some server like nginx, apache, etc. Path normalization is performed on the root server level but still the actual client's request path will be sent to vendure service but not the resultant normalized path. However, depending the type of root server one can try various payloads to bypass such normalization.
The reporter found a customer website which uses local asset plugin and using above mentioned vulnerability, and was able to find secrets like email credentials.
DOS via malformed URI
In the same code path is an additional vector for crashing the server via a malformed URI
Again from Rajesh:
There is also a potential Denial of Service (DoS) issue when incorrectly encoded URI characters are passed as part of the asset URL. When these malformed requests are processed, they can lead to system crashes or resource exhaustion, rendering the service unavailable to users.
Exploit: curl --path-as-is http://localhost:3000/assets/%80package.json , here %80 is not a valid url-encoded character hence the decodeURIComponent is called on it, the entire app crashes.
[:server] /Users/abc/mywork/vendure/packages/asset-server-plugin/src/plugin.ts:353
[:server] const decodedReqPath = decodeURIComponent(req.path);
[:server] ^
[:server] URIError: URI malformed
Patches
v3.0.5, v2.3.3
Workarounds
- Use object storage rather than the local file system, e.g. MinIO or S3
- Define middleware which detects and blocks requests with urls containing
/../
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @vendure/asset-server-plugin | all versions | 2.3.3npm install @vendure/asset-server-plugin@2.3.3 |
| 📦npm | @vendure/asset-server-plugin | ≥ 3.0.0&&< 3.0.5 | 3.0.5npm install @vendure/asset-server-plugin@3.0.5 |
Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @vendure/asset-server-plugin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @vendure/asset-server-plugin to 2.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-48914 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
How to detect CVE-2024-48914
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2024-48914 -u https://target- Template
- Vendure - Arbitrary File Read
- Severity
- critical
- Impact
- Allows attackers to read arbitrary files on the server, including sensitive data such as configuration files and environment variables.
- Remediation
- Patches are available in versions 3.0.5 and 2.3.3. Some workarounds are also available. One may use object storage rather than the local file system, e.g. MinIO or S3, or define middleware which detects and blocks requests with urls containing `/../`.
Template by ProjectDiscovery nuclei-templates (s4e-io), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2024-48914 in your dependencies?
Find it across npm, including transitive dependencies.