CVE-2024-48910 is a critical-severity (CVSS 9.1) CWE-1321 vulnerability in dompurify. A fix is available for dompurify — see the affected versions and patch details below.
DOMPurify vulnerable to tampering by prototype polution
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-48910.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
dompurifynpmDescription
DOMPurify is a DOM-only, super-fast, uber-tolerant XSS sanitizer for HTML, MathML and SVG. DOMPurify was vulnerable to prototype pollution. This vulnerability is fixed in 2.4.2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | dompurify | all versions | 2.4.2npm install dompurify@2.4.2 |
Affected Products
dompurifycure53Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dompurify, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update dompurify to 2.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-48910 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The prototype pollution vulnerability in DOMPurify is considered a high-severity issue because it allows attackers to modify the prototype of built-in JavaScript objects, potentially impacting the entire application. This could lead to security risks, such as overwriting methods on fundamental objects like `Object`,…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-48910 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Advanced Cluster Security 4.4 | advanced-cluster-security/rhacs-main-rhel8:4.4.6-2 | RHSA-2024:9583 |
| Red Hat Advanced Cluster Security 4.5 | advanced-cluster-security/rhacs-main-rhel8:4.5.5-3 | RHSA-2024:10186 |
| Red Hat OpenShift Container Platform 4.14 | openshift4/ose-monitoring-plugin-rhel8:v4.14.0-202411130434.p0.gb57ebe7.assembly.stream.el8 | RHSA-2024:9620 |
| Red Hat OpenShift Container Platform 4.17 | openshift4/ose-networking-console-plugin-rhel9:v4.17.0-202501150934.p0.g0244dff.assembly.stream.el9 | RHSA-2025:0654 |
| Red Hat OpenShift Container Platform 4.17 | openshift4/nmstate-console-plugin-rhel9:v4.17.0-202501301204.p0.gcffdc60.assembly.stream.el9 | RHSA-2025:0875 |
| Red Hat OpenShift Container Platform 4.18 | openshift4/ingress-node-firewall-rhel9:v4.18.0-202501230001.p0.g1e43b4c.assembly.stream.el9 | RHSA-2024:6121 |
| Red Hat OpenShift Container Platform 4.18 | openshift4/aws-kms-encryption-provider-rhel9:v4.18.0-202501230001.p0.g088dcaf.assembly.stream.el9 | RHSA-2024:6122 |
| RHODF-4.14-RHEL-9 | odf4/ocs-client-console-rhel9:v4.14.18-2 | RHSA-2025:8551 |
Frequently Asked Questions
Is CVE-2024-48910 in your dependencies?
Find it across npm, including transitive dependencies.