CVE-2024-47875 is a critical-severity (CVSS 10) Cross-site Scripting (XSS) vulnerability in dompurify. A fix is available for dompurify — see the affected versions and patch details below.
DOMPurify nesting-based mXSS
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-47875.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
dompurifynpmDescription
DOMPurify is a DOM-only, super-fast, uber-tolerant XSS sanitizer for HTML, MathML and SVG. DOMpurify was vulnerable to nesting-based mXSS. This vulnerability is fixed in 2.5.0 and 3.1.3.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | dompurify | all versions | 2.5.0npm install dompurify@2.5.0 |
| 📦npm | dompurify | ≥ 3.0.0&&< 3.1.3 | 3.1.3npm install dompurify@3.1.3 |
Affected Products
dompurifycure53Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dompurify, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update dompurify to 2.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-47875 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-47875 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 8 | grafana-0:9.2.10-20.el8_10 | RHSA-2024:8327 |
| Red Hat Enterprise Linux 9 | grafana-0:9.2.10-19.el9_4 | RHSA-2024:8678 |
| Red Hat Enterprise Linux 9 | grafana-0:10.2.6-7.el9_5 | RHSA-2024:9473 |
| Red Hat OpenShift Container Platform 4.14 | openshift4/ose-monitoring-plugin-rhel8:v4.14.0-202411130434.p0.gb57ebe7.assembly.stream.el8 | RHSA-2024:9620 |
| Red Hat OpenShift Container Platform 4.15 | openshift4/ose-monitoring-plugin-rhel8:v4.15.0-202411060036.p0.ge40b085.assembly.stream.el8 | RHSA-2024:8991 |
| Red Hat OpenShift Container Platform 4.16 | openshift4/ose-monitoring-plugin-rhel9:v4.16.0-202410300036.p0.g442ccd1.assembly.stream.el9 | RHSA-2024:8683 |
| Red Hat OpenShift Container Platform 4.17 | openshift4/ose-monitoring-plugin-rhel9:v4.17.0-202410300235.p0.g9c9c0a0.assembly.stream.el9 | RHSA-2024:8981 |
| Red Hat OpenShift Dev Spaces 3 Containers | devspaces/code-rhel8:3.17-19 | RHSA-2024:10236 |
Frequently Asked Questions
Is CVE-2024-47875 in your dependencies?
Find it across npm, including transitive dependencies.