CVE-2024-47616 is a medium-severity (CVSS 6.8) CWE-863 vulnerability in github.com/pomerium/pomerium. A fix is available for github.com/pomerium/pomerium — see the affected versions and patch details below.
Pomerium's service account access token may grant unintended access to databroker API
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-47616.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/pomerium/pomeriumReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
We've identified a vulnerability in the Pomerium databroker service API that may grant unintended access under specific conditions. This affects only certain Pomerium Zero and Pomerium Enterprise deployments.
Who is affected?
A Pomerium deployment is susceptible to this issue if all of the following conditions are met:
- You have issued a service account access token using Pomerium Zero or Pomerium Enterprise.
- The access token has an explicit expiration date in the future.
- The core Pomerium databroker gRPC API is not otherwise secured by network access controls.
If your deployment does not meet all of these conditions, you are not affected by this vulnerability.
Details
The Pomerium databroker service is responsible for managing all persistent Pomerium application state. Requests to the databroker service API are authorized by the presence of a JSON Web Token (JWT) signed by a key known by all Pomerium services in the same deployment. However, incomplete validation of this JWT meant that some service account access tokens would incorrectly be treated as valid for the purpose of databroker API authorization.
Improper access to the databroker API could allow exfiltration of user info, spoofing of user sessions, or tampering with Pomerium routes, policies, and other settings.
Discovery
This issue was discovered during internal review. At this time we have no evidence to suggest that this vulnerability has been exploited in the wild.
Patches
We have released Pomerium v0.27.1 which includes a fix for the JWT validation logic. All affected users are strongly encouraged to upgrade to this version.
Workarounds
If you cannot upgrade immediately, consider the following mitigations:
-
Network access controls: Restrict access to the Pomerium internal gRPC API by configuring your network firewall or security groups to limit access to trusted sources only. Ensure that the port specified in the
grpc_addresssetting is not exposed to unauthorized networks. -
For Pomerium Zero deployments only: As of Pomerium v0.26.0, you can disable the gRPC API listener by setting
grpc_address: ""in your YAML configuration file. In all-in-one mode, Pomerium does not require the internal gRPC API to be exposed beyond localhost.
For more information
If you have questions or need further assistance:
- Open an issue in the pomerium/pomerium repository.
- Contact us at [email protected].
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/pomerium/pomerium | all versions | 0.27.1go get github.com/pomerium/pomerium@v0.27.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/pomerium/pomerium, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/pomerium/pomerium to 0.27.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-47616 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-47616 in your dependencies?
Find it across Go, including transitive dependencies.