CVE-2022-24797 is a medium-severity (CVSS 6.5) Information Exposure vulnerability in github.com/pomerium/pomerium. A fix is available for github.com/pomerium/pomerium — see the affected versions and patch details below.
Exposure of Sensitive Information in Pomerium
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24797.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/pomerium/pomeriumReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
In distributed service mode, Pomerium's Authenticate service exposes pprof debug and prometheus metrics handlers to untrusted traffic. This can leak potentially sensitive environmental information or lead to limited denial of service conditions.
Patches
v0.17.1
Workarounds
Block access to /debug and /metrics paths on the authenticate service. This can be done with any L7 proxy, including Pomerium's own proxy service.
References
https://github.com/pomerium/pomerium/pull/3212
For more information
If you have any questions or comments about this advisory:
- Open an issue in Pomerium
- Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/pomerium/pomerium | ≥ 0.16.0&&< 0.17.1 | 0.17.1go get github.com/pomerium/pomerium@v0.17.1 |
Affected Products
pomeriumpomeriumDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/pomerium/pomerium, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/pomerium/pomerium to 0.17.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24797 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2022-24797 in your dependencies?
Find it across Go, including transitive dependencies.