CVE-2024-47554 — commons-io
MEDIUMCVE-2024-47554 is a medium-severity (CVSS 4.3) Uncontrolled Resource Consumption vulnerability in commons-io:commons-io. A fix is available for commons-io:commons-io — see the affected versions and patch details below.
Apache Commons IO: Possible denial of service attack on untrusted input to XmlStreamReader
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-47554.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
commons-io:commons-ioReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Uncontrolled Resource Consumption vulnerability in Apache Commons IO.
The org.apache.commons.io.input.XmlStreamReader class may excessively consume CPU resources when processing maliciously crafted input.
This issue affects Apache Commons IO: from 2.0 before 2.14.0.
Users are recommended to upgrade to version 2.14.0 or later, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | commons-io:commons-io | ≥ 2.0&&< 2.14.0 | 2.14.0commons-io:commons-io:2.14.0 |
Affected Products
commons ioapacheactive iq unified managernetappbluexpnetappe-series santricity unified managernetappe-series santricity web services proxynetappontap toolsnetappDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for commons-io:commons-io, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update commons-io:commons-io to 2.14.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-47554 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss Enterprise Application Platform 7.4.22 | commons-io/commons-io:2.16.1.redhat-00001 | RHSA-2025:4552 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8 | eap7-apache-commons-io-0:2.16.1-1.redhat_00001.1.el8eap | RHSA-2025:4549 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 9 | eap7-apache-commons-io-0:2.16.1-1.redhat_00001.1.el9eap | RHSA-2025:4550 |
| Red Hat JBoss Enterprise Application Platform 7.4 on RHEL 7 | eap7-apache-commons-io-0:2.16.1-1.redhat_00001.1.el7eap | RHSA-2025:4548 |
| Red Hat JBoss Enterprise Application Platform 8 | see advisory | RHSA-2024:8826 |
| Red Hat JBoss Enterprise Application Platform 8.0 for RHEL 8 | eap8-activemq-artemis-0:2.33.0-1.redhat_00015.1.el8eap | RHSA-2024:8823 |
| Red Hat JBoss Enterprise Application Platform 8.0 for RHEL 9 | eap8-activemq-artemis-0:2.33.0-1.redhat_00015.1.el9eap | RHSA-2024:8824 |
| Streams for Apache Kafka 2.8.0 | see advisory | RHSA-2024:9571 |
Frequently Asked Questions
Is CVE-2024-47554 in your dependencies?
Find it across Maven, including transitive dependencies.