NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2021-29425 — commons-io

MEDIUM

CVE-2021-29425 is a medium-severity (CVSS 4.8) Improper Input Validation vulnerability in commons-io:commons-io. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for commons-io:commons-io — see the affected versions and patch details below.

Path Traversal and Improper Input Validation in Apache Commons IO

Also known asGHSA-gwrp-pvrq-jmwv
Published
Updated
Affected
10 pkgs
Patched
2 / 10
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2021-29425.

EPSS Exploitation Probability

via FIRST.org ↗
10.5%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
0.00%4.55%9.10%13.6%0.5%10.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

10 pkgs affected
☕commons-io:commons-io☕com.cosium.vet:vet☕com.diamondq.common:common-thirdparty.jcasbin☕com.liferay:com.liferay.sass.compiler.jsass☕com.virjar:ratel-api☕net.hasor:cobble-lang☕org.apache.commons:commons-io☕org.apache.servicemix.bundles:org.apache.servicemix.bundles.commons-io+2 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache Commons IO before 2.7, When invoking the method FileNameUtils.normalize with an improper input string, like "//../foo", or "\..\foo", the result would be the same value, thus possibly providing access to files in the parent directory, but not further above (thus "limited" path traversal), if the calling code would use the result to construct a path value.

Affected Packages

10 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencommons-io:commons-ioall versions2.7commons-io:commons-io:2.7
☕Mavencom.cosium.vet:vet≥ 1.0No fix
☕Mavencom.diamondq.common:common-thirdparty.jcasbinall versionsNo fix
☕Mavencom.liferay:com.liferay.sass.compiler.jsassall versionsNo fix
☕Mavencom.virjar:ratel-api≥ 1.0.0No fix
☕Mavennet.hasor:cobble-lang≥ 4.4.1No fix

Affected Products

60 products · 136 configurations
Application
commons ioapache
5 versions
2.22.32.42.52.6
OS
debian linuxdebian
1 version
9.0
Application
active iq unified managernetapp
all
Application
access manageroracle
3 versions
11.1.2.3.012.2.1.3.012.2.1.4.0
Application
agile engineering data managementoracle
1 version
6.2.1.0
Application
agile product lifecycle managementoracle
1 version
9.3.6
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for commons-io:commons-io, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update commons-io:commons-io to 2.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-29425 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

While the apache-commons-io package included in Red Hat Enterprise Linux 8 Maven App Stream contains the vulnerable code, it is not used in any way by Maven or other packages in this module. This package is not an API component of Maven, thus the affected code can not be reached in any supported scenario.

ProductFixed inAdvisory
EAP 7.3.9 releasecommons-ioRHSA-2021:3471
Red Hat AMQ 7.9.0commons-ioRHSA-2021:3700
Red Hat AMQ Streams 1.8.0commons-ioRHSA-2021:3225
Red Hat EAP-XP 2.0.0 via EAP 7.3.x basecommons-ioRHSA-2021:3516
Red Hat Fuse 7.10commons-ioRHSA-2021:5134
Red Hat JBoss Enterprise Application Platformcommons-io/commons-io:2.10.0.redhat-00001RHSA-2021:3660
Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 6eap7-apache-commons-io-0:2.10.0-1.redhat_00001.1.el6eapRHSA-2021:3466
Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 7eap7-apache-commons-io-0:2.10.0-1.redhat_00001.1.el7eapRHSA-2021:3467

Frequently Asked Questions

In Apache Commons IO before 2.7, When invoking the method FileNameUtils.normalize with an improper input string, like "//../foo", or "\\..\foo", the result would be the same value, thus possibly providing access to files in the parent directory, but not further above (thus "limited" path traversal), if the calling code would use the result to construct a path value.
O3 Security · Impact-Aware SCA

Is CVE-2021-29425 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-29425: commons-io Path Traversal — Fixed in 2.7