CVE-2024-47058 is a low-severity (CVSS 2.9) Cross-site Scripting (XSS) vulnerability in mautic/core. A fix is available for mautic/core — see the affected versions and patch details below.
Cross-site Scripting (XSS) - stored (edit form HTML field)
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-47058.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mautic/core🐘mautic/core🐘mautic/core-lib🐘mautic/core-libReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
With access to edit a Mautic form, the attacker can add Cross-Site Scripting stored in the html filed. This could be used to steal sensitive information from the user's current session.
Patches
Upgrade to 4.4.13 or 5.1.1 or later.
Workarounds
None
References
- https://owasp.org/www-project-top-ten/2017/A7_2017-Cross-Site_Scripting_(XSS)
- https://owasp.org/www-project-web-security-testing-guide/latest/4-Web_Application_Security_Testing/07-Input_Validation_Testing/02-Testing_for_Stored_Cross_Site_Scripting
If you have any questions or comments about this advisory:
Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mautic/core | ≥ 5.0.0-alpha&&< 5.1.1 | 5.1.1composer require mautic/core:^5.1.1 |
| 🐘Packagist | mautic/core | ≥ 1.0.0-beta&&< 4.4.13 | 4.4.13composer require mautic/core:^4.4.13 |
| 🐘Packagist | mautic/core-lib | ≥ 5.0.0-alpha&&< 5.1.1 | 5.1.1composer require mautic/core-lib:^5.1.1 |
| 🐘Packagist | mautic/core-lib | ≥ 1.0.0-beta&&< 4.4.13 | 4.4.13composer require mautic/core-lib:^4.4.13 |
Affected Products
mauticacquiaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mautic/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mautic/core to 5.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-47058 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-47058 in your dependencies?
Find it across Packagist, including transitive dependencies.