NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2026-3105 — core

HIGH

CVE-2026-3105 is a high-severity (CVSS 7.6) SQL Injection vulnerability in mautic/core. A fix is available for mautic/core — see the affected versions and patch details below.

SQL Injection in Contact Activity API Sorting

Also known asGHSA-r5j5-q42h-fc93
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-3105.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs26th percentile — riskier than 26% of all scored CVEsHighest risk
0.00%0.30%0.59%0.89%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘mautic/core🐘mautic/core🐘mautic/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Summary

This advisory addresses a SQL Injection vulnerability in the API endpoint used for retrieving contact activities. A vulnerability exists in the query construction for the Contact Activity timeline where the parameter responsible for determining the sort direction was not strictly validated against an allowlist, potentially allowing authenticated users to inject arbitrary SQL commands via the API.

Mitigation

Please update to 5.2.10, 6.0.8, 7.0.1 or later.

Workarounds

None.

References

If there are any questions or comments about this advisory:

Email Mautic at [email protected]

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmautic/core≥ 2.10.0&&< 5.2.105.2.10composer require mautic/core:^5.2.10
🐘Packagistmautic/core≥ 6.0.0-alpha&&< 6.0.86.0.8composer require mautic/core:^6.0.8
🐘Packagistmautic/core≥ 7.0.0-alpha&&< 7.0.17.0.1composer require mautic/core:^7.0.1

Affected Products

1 product · 4 configurations
Application
mauticacquia
≥ 7.0.0 && < 7.0.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mautic/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mautic/core to 5.2.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-3105 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

### Summary This advisory addresses a SQL Injection vulnerability in the API endpoint used for retrieving contact activities. A vulnerability exists in the query construction for the Contact Activity timeline where the parameter responsible for determining the sort direction was not strictly validated against an allowlist, potentially allowing authenticated users to inject arbitrary SQL commands via the API. ### Mitigation Please update to **5.2.10**, **6.0.8**, **7.0.1** or later. ### Workarounds None. ### References If there are any questions or comments about this advisory: Email Mau
O3 Security · Impact-Aware SCA

Is CVE-2026-3105 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-3105: core SQL Injection — Fixed in 5.2.10