NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2024-45792 — mantisbt

Fix: mantisbt/mantisbt@ef0f820

CVE-2024-45792 is a Information Exposure vulnerability in mantisbt/mantisbt. A fix is available for mantisbt/mantisbt — see the affected versions and patch details below.

MantisBT vulnerable to information disclosure with user profiles

Also known asGHSA-h5q3-fjp4-2x7r
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-45792.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.02%0.40%0.78%1.16%0.7%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘mantisbt/mantisbt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Using a crafted POST request, an unprivileged, registered user is able to retrieve information about other users' personal system profiles.

Impact

Disclosure of private system profiles: Platform, OS, OS version, Description.

Patches

Workarounds

None

References

https://mantisbt.org/bugs/view.php?id=34640

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmantisbt/mantisbtall versions2.26.4composer require mantisbt/mantisbt:^2.26.4

Affected Products

1 product · 1 configurations
Application
mantisbtmantisbt
< 2.26.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mantisbt/mantisbt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mantisbt/mantisbt to 2.26.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-45792 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Using a crafted POST request, an unprivileged, registered user is able to retrieve information about other users' personal system profiles. ### Impact Disclosure of private system profiles: Platform, OS, OS version, Description. ### Patches - https://github.com/mantisbt/mantisbt/commit/56bbd02dc1fb33a8de5898fd17dc3d698c847f55 ### Workarounds None ### References https://mantisbt.org/bugs/view.php?id=34640
O3 Security · Impact-Aware SCA

Is CVE-2024-45792 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-45792: mantisbt — Fixed in 2.26.4