CVE-2024-45477 is a medium-severity (CVSS 4.6) Cross-site Scripting (XSS) vulnerability in org.apache.nifi:nifi-web-ui. A fix is available for org.apache.nifi:nifi-web-ui — see the affected versions and patch details below.
Apache NiFi: Improper Neutralization of Input in Parameter Description
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-45477.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.nifi:nifi-web-ui☕org.apache.nifi:nifi-web-uiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache NiFi 1.10.0 through 1.27.0 and 2.0.0-M1 through 2.0.0-M3 support a description field for Parameters in a Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.28.0 or 2.0.0-M4 is the recommended mitigation.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.nifi:nifi-web-ui | ≥ 1.10.0&&< 1.28.0 | 1.28.0org.apache.nifi:nifi-web-ui:1.28.0 |
| ☕Maven | org.apache.nifi:nifi-web-ui | ≥ 2.0.0-M1&&< 2.0.0-M4 | 2.0.0-M4org.apache.nifi:nifi-web-ui:2.0.0-M4 |
Affected Products
nifiapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.nifi:nifi-web-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.nifi:nifi-web-ui to 1.28.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-45477 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-45477 in your dependencies?
Find it across Maven, including transitive dependencies.