CVE-2024-45233 is a high-severity (CVSS 7.3) CWE-284 vulnerability in in2code/powermail. A fix is available for in2code/powermail — see the affected versions and patch details below.
Powermail TYPO3 extension Broken Access Control in the OutputController
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-45233.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
in2code/powermail🐘in2code/powermail🐘in2code/powermail🐘in2code/powermailReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in powermail extension through 12.3.5 for TYPO3. Several actions in the OutputController can directly be called, due to missing or insufficiently implemented access checks, resulting in Broken Access Control. Depending on the configuration of the Powermail Frontend plugins, an unauthenticated attacker can exploit this to edit, update, delete, or export data of persisted forms. This can only be exploited when the Powermail Frontend plugins are used. The fixed versions are 7.5.0, 8.5.0, 10.9.0, and 12.4.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | in2code/powermail | all versions | 7.5.0composer require in2code/powermail:^7.5.0 |
| 🐘Packagist | in2code/powermail | ≥ 8.0.0&&< 8.5.0 | 8.5.0composer require in2code/powermail:^8.5.0 |
| 🐘Packagist | in2code/powermail | ≥ 9.0.0&&< 10.9.0 | 10.9.0composer require in2code/powermail:^10.9.0 |
| 🐘Packagist | in2code/powermail | ≥ 11.0.0&&< 12.4.0 | 12.4.0composer require in2code/powermail:^12.4.0 |
Affected Products
powermailin2codeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for in2code/powermail, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update in2code/powermail to 7.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-45233 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-45233 in your dependencies?
Find it across Packagist, including transitive dependencies.