NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2012-5889 — powermail

CVE-2012-5889 is a Cross-site Scripting (XSS) vulnerability in in2code/powermail. A fix is available for in2code/powermail — see the affected versions and patch details below.

powermail extension for TYPO3 has Cross-site Scripting vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.48%0.95%1.43%0.3%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘in2code/powermail

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the powermail extension before 1.6.5 for TYPO3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistin2code/powermailall versions1.6.5composer require in2code/powermail:^1.6.5

Affected Products

1 product · 66 configurations
Application
powermailalex_kellner
≤ 1.6.4
65 versions
1.0.11.0.21.0.31.0.41.0.51.0.61.0.71.0.81.0.91.0.101.0.111.0.12

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for in2code/powermail, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update in2code/powermail to 1.6.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-5889 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the powermail extension before 1.6.5 for TYPO3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2012-5889 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2012-5889: powermail XSS — Fixed in 1.6.5