CVE-2024-43376 is a medium-severity (CVSS 4.3) CWE-209 vulnerability in Umbraco.Cms.Api.Management. A fix is available for Umbraco.Cms.Api.Management — see the affected versions and patch details below.
Umbraco CMS vulnerable to Generation of Error Message Containing Sensitive Information
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-43376.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Umbraco.Cms.Api.ManagementReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Some endpoints in the Management API can return stack trace information, even when Umbraco is not in debug mode.
Explanation of the vulnerability
Management API endpoints leaked stack traces in case of Internal server errors, no matter if the debug setting was disabled.
E.g. when paging with negative numbers in some apis
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Umbraco.Cms.Api.Management | ≥ 14.0.0&&< 14.1.2 | 14.1.2dotnet add package Umbraco.Cms.Api.Management --version 14.1.2 |
Affected Products
umbraco cmsumbracoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Umbraco.Cms.Api.Management, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Umbraco.Cms.Api.Management to 14.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-43376 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-43376 in your dependencies?
Find it across NuGet, including transitive dependencies.