CVE-2024-41799 is a high-severity (CVSS 8.4) Path Traversal vulnerability in Tgstation.Server.Api. A fix is available for Tgstation.Server.Api — see the affected versions and patch details below.
tgstation-server's DreamMaker environment files outside the deployment directory can be compiled and ran by insufficiently permissioned users
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-41799.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Tgstation.Server.Api.NETTgstation.Server.HostReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
Impact
What kind of vulnerability is it? Who is impacted?
Low permission users using the "Set .dme Path" privilege could potentially set malicious .dme files existing on the host machine to be compiled and executed.
These .dme files could be uploaded via tgstation-server (requiring a separate, isolated privilege) or some other means.
A server configured to execute in BYOND's trusted security level (requiring a third separate, isolated privilege OR being set by another user) could lead to this escalating into remote code execution via BYOND's shell() proc.
The ability to execute this kind of attack is a known side effect of having privileged TGS users, but normally requires multiple privileges with known weaknesses. This vector is not intentional as it does not require control over the where deployment code is sourced from and may not require remote write access to an instance's Configuration directory.
Patches
Has the problem been patched? What versions should users upgrade to?
This problem is patched by pull request #1835 and fixed in versions 6.8.0 and above.
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading?
Do not give un-trusted users the Deployment permission to set a .dme path on instances.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Tgstation.Server.Api | ≥ 4.0.0&&< 6.8.0 | 6.8.0dotnet add package Tgstation.Server.Api --version 6.8.0 |
| .NETNuGet | Tgstation.Server.Host | ≥ 4.0.0&&< 6.8.0 | 6.8.0dotnet add package Tgstation.Server.Host --version 6.8.0 |
Affected Products
tgstation-servertgstation13Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Tgstation.Server.Api, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Tgstation.Server.Api to 6.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-41799 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2024-41799 in your dependencies?
Find it across NuGet, including transitive dependencies.