NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-39319 — ai-controller-frontend

MEDIUMFix: aimeos/ai-controller-frontend@2ad5c06

CVE-2024-39319 is a medium-severity (CVSS 5.3) CWE-639 vulnerability in aimeos/ai-controller-frontend. A fix is available for aimeos/ai-controller-frontend — see the affected versions and patch details below.

aimeos/ai-controller-frontend has IDOR vulnerability in account profile page

Also known asGHSA-rw3j-574h-mrcq
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs42th percentile — riskier than 42% of all scored CVEsHighest risk
0.00%0.35%0.71%1.06%0.6%0.5%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐘aimeos/ai-controller-frontend🐘aimeos/ai-controller-frontend🐘aimeos/ai-controller-frontend🐘aimeos/ai-controller-frontend🐘aimeos/ai-controller-frontend

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

aimeos/ai-controller-frontend is the Aimeos frontend controller package for e-commerce projects. Prior to versions 2024.4.2, 2023.10.9, 2022.10.8, 2021.10.8, and 2020.10.15, an insecure direct object reference allows an attacker to disable subscriptions and reviews of another customer. Versions 2024.4.2, 2023.10.9, 2022.10.8, 2021.10.8, and 2020.10.15 fix this issue.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistaimeos/ai-controller-frontend≥ 2024.04.1&&< 2024.04.22024.04.2composer require aimeos/ai-controller-frontend:^2024.04.2
🐘Packagistaimeos/ai-controller-frontend≥ 2023.04.1&&< 2023.10.92023.10.9composer require aimeos/ai-controller-frontend:^2023.10.9
🐘Packagistaimeos/ai-controller-frontend≥ 2022.04.1&&< 2022.10.82022.10.8composer require aimeos/ai-controller-frontend:^2022.10.8
🐘Packagistaimeos/ai-controller-frontend≥ 2021.04.1&&< 2021.10.82021.10.8composer require aimeos/ai-controller-frontend:^2021.10.8
🐘Packagistaimeos/ai-controller-frontendall versions2020.10.15composer require aimeos/ai-controller-frontend:^2020.10.15

Affected Products

1 product · 5 configurations
Application
aimeos frontend controlleraimeos
≥ 2023.04.1 && < 2023.10.9
1 version
2024.04.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aimeos/ai-controller-frontend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update aimeos/ai-controller-frontend to 2024.04.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-39319 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

aimeos/ai-controller-frontend is the Aimeos frontend controller package for e-commerce projects. Prior to versions 2024.4.2, 2023.10.9, 2022.10.8, 2021.10.8, and 2020.10.15, an insecure direct object reference allows an attacker to disable subscriptions and reviews of another customer. Versions 2024.4.2, 2023.10.9, 2022.10.8, 2021.10.8, and 2020.10.15 fix this issue.
O3 Security · Impact-Aware SCA

Is CVE-2024-39319 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-39319: ai-controller-frontend — Fixed in 2024.04.2