NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2024-38988 — @alizeait/unflatto

CRITICALFix: alizeait/unflatto@3c1b120

CVE-2024-38988 is a critical-severity (CVSS 9.8) CWE-1321 vulnerability in @alizeait/unflatto. A fix is available for @alizeait/unflatto — see the affected versions and patch details below.

@alizeait/unflatto Prototype Pollution

Also known asGHSA-q8jq-4rm5-4hm5
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-38988.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.92%1.37%0.4%0.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@alizeait/unflattonpm
547downloads / week

Description

Impact

alizeait unflatto <= 1.0.2 was discovered to contain a prototype pollution via the method exports.unflatto at /dist/index.js. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.

Patches

The problem has been patched in 1.0.3

References

https://github.com/advisories/GHSA-799q-f2px-wx8c

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@alizeait/unflattoall versions1.0.3npm install @alizeait/unflatto@1.0.3

Affected Products

1 product · 1 configurations
Application
unflattoalizeait
≤ 1.0.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @alizeait/unflatto, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @alizeait/unflatto to 1.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-38988 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact alizeait unflatto <= 1.0.2 was discovered to contain a prototype pollution via the method exports.unflatto at /dist/index.js. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties. ### Patches The problem has been patched in 1.0.3 ### References https://github.com/advisories/GHSA-799q-f2px-wx8c
O3 Security · Impact-Aware SCA

Is CVE-2024-38988 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-38988: @alizeait/unflatto RCE — Fixed in 1.0.3