CVE-2024-38874 — events2
MEDIUMCVE-2024-38874 is a medium-severity (CVSS 5.4) CWE-693 vulnerability in jweiland/events2. A fix is available for jweiland/events2 — see the affected versions and patch details below.
events2 TYPO3 extension insecure direct object reference (IDOR) vulnerability
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-38874.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
jweiland/events2🐘jweiland/events2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in the events2 (aka Events 2) extension before 8.3.8 and 9.x before 9.0.6 for TYPO3. Missing access checks in the management plugin lead to an insecure direct object reference (IDOR) vulnerability with the potential to activate or delete various events for unauthenticated users.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | jweiland/events2 | all versions | 8.3.8composer require jweiland/events2:^8.3.8 |
| 🐘Packagist | jweiland/events2 | ≥ 9.0.0&&< 9.0.6 | 9.0.6composer require jweiland/events2:^9.0.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jweiland/events2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update jweiland/events2 to 8.3.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-38874 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-38874 in your dependencies?
Find it across Packagist, including transitive dependencies.