NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2024-38516 — ai-client-html

HIGHFix: aimeos/ai-client-html@bb38962

CVE-2024-38516 is a high-severity (CVSS 8.8) CWE-1295 vulnerability in aimeos/ai-client-html. A fix is available for aimeos/ai-client-html — see the affected versions and patch details below.

Aimeos HTML client may potentially reveal sensitive information in error log

Also known asGHSA-ppm5-jv84-2xg2
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-38516.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs44th percentile — riskier than 44% of all scored CVEsHighest risk
0.00%0.34%0.67%1.01%0.3%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘aimeos/ai-client-html🐘aimeos/ai-client-html🐘aimeos/ai-client-html🐘aimeos/ai-client-html

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

ai-client-html is an Aimeos e-commerce HTML client component. Debug information revealed sensitive information from environment variables in error log. This issue has been patched in versions 2024.04.7, 2023.10.15, 2022.10.13 and 2021.10.22.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistaimeos/ai-client-html≥ 2024.04.1&&< 2024.04.72024.04.7composer require aimeos/ai-client-html:^2024.04.7
🐘Packagistaimeos/ai-client-html≥ 2023.04.1&&< 2023.10.152023.10.15composer require aimeos/ai-client-html:^2023.10.15
🐘Packagistaimeos/ai-client-html≥ 2022.04.1&&< 2022.10.132022.10.13composer require aimeos/ai-client-html:^2022.10.13
🐘Packagistaimeos/ai-client-html≥ 2021.10.1&&< 2021.10.222021.10.22composer require aimeos/ai-client-html:^2021.10.22

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aimeos/ai-client-html, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update aimeos/ai-client-html to 2024.04.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-38516 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

ai-client-html is an Aimeos e-commerce HTML client component. Debug information revealed sensitive information from environment variables in error log. This issue has been patched in versions 2024.04.7, 2023.10.15, 2022.10.13 and 2021.10.22.
O3 Security · Impact-Aware SCA

Is CVE-2024-38516 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-38516: ai-client-html — Fixed in 2024.04.7