CVE-2024-37296 is a medium-severity (CVSS 5.3) CWE-841 vulnerability in aimeos/ai-client-html. A fix is available for aimeos/ai-client-html — see the affected versions and patch details below.
Aimeos HTML client vulnerable to digital products download without proper payment status check
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-37296.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
aimeos/ai-client-html🐘aimeos/ai-client-html🐘aimeos/ai-client-html🐘aimeos/ai-client-html🐘aimeos/ai-client-htmlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The Aimeos HTML client provides Aimeos HTML components for e-commerce projects. Starting in version 2020.04.1 and prior to versions 2020.10.27, 2021.10.21, 2022.10.12, 2023.10.14, and 2024.04.5, digital downloads sold in online shops can be downloaded without valid payment, e.g. if the payment didn't succeed. Versions 2020.10.27, 2021.10.21, 2022.10.12, 2023.10.14, and 2024.04.5 fix this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | aimeos/ai-client-html | ≥ 2024.04.1&&< 2024.04.5 | 2024.04.5composer require aimeos/ai-client-html:^2024.04.5 |
| 🐘Packagist | aimeos/ai-client-html | ≥ 2023.04.1&&< 2023.10.14 | 2023.10.14composer require aimeos/ai-client-html:^2023.10.14 |
| 🐘Packagist | aimeos/ai-client-html | ≥ 2022.04.1&&< 2022.10.12 | 2022.10.12composer require aimeos/ai-client-html:^2022.10.12 |
| 🐘Packagist | aimeos/ai-client-html | ≥ 2021.04.1&&< 2021.10.21 | 2021.10.21composer require aimeos/ai-client-html:^2021.10.21 |
| 🐘Packagist | aimeos/ai-client-html | ≥ 2020.04.1&&< 2020.10.27 | 2020.10.27composer require aimeos/ai-client-html:^2020.10.27 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aimeos/ai-client-html, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update aimeos/ai-client-html to 2024.04.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-37296 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-37296 in your dependencies?
Find it across Packagist, including transitive dependencies.