CVE-2024-3727 is a high-severity (CVSS 8.3) CWE-354 vulnerability in github.com/containers/image. A fix is available for github.com/containers/image — see the affected versions and patch details below.
Containers/image: digest type does not guarantee valid type
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-3727.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/containers/image🐹github.com/containers/image/v5🐹github.com/containers/image/v5Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in the github.com/containers/image library. This flaw allows attackers to trigger unexpected authenticated registry accesses on behalf of a victim user, causing resource exhaustion, local path traversal, and other attacks.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/containers/image | all versions | 5.30.1go get github.com/containers/image@v5.30.1 |
| 🐹Go | github.com/containers/image/v5 | ≥ 5.30.0&&< 5.30.1 | 5.30.1go get github.com/containers/image/v5@v5.30.1 |
| 🐹Go | github.com/containers/image/v5 | all versions | 5.29.3go get github.com/containers/image/v5@v5.29.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/containers/image, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/containers/image to 5.30.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-3727 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Some conditions are necessary for this attack to occur, such as the attacker being able to upload malicious images to the registry and persuade a victim to pull them. Hence, the severity of this flaw was rated as Moderate.
| Product | Fixed in | Advisory |
|---|---|---|
| OADP-1.3-RHEL-9 | oadp/oadp-velero-plugin-rhel9:1.3.4-9 | RHSA-2024:9960 |
| Red Hat Advanced Cluster Security 4.4 | advanced-cluster-security/rhacs-central-db-rhel8:4.4.5-2 | RHSA-2024:6054 |
| Red Hat Advanced Cluster Security 4.5 | advanced-cluster-security/rhacs-central-db-rhel8:4.5.2-2 | RHSA-2024:6708 |
| Red Hat Enterprise Linux 8 | container-tools:rhel8-8100020240808093819.afee755d | RHSA-2024:5258 |
| Red Hat Enterprise Linux 9 | buildah-2:1.37.2-1.el9 | RHSA-2024:9097 |
| Red Hat Enterprise Linux 9 | skopeo-2:1.16.1-1.el9 | RHSA-2024:9098 |
| Red Hat Enterprise Linux 9 | podman-2:5.2.2-1.el9 | RHSA-2024:9102 |
| Red Hat Migration Toolkit for Containers 1.8 | rhmtc/openshift-migration-controller-rhel8:v1.8.4-22 | RHSA-2024:7164 |
Frequently Asked Questions
Is CVE-2024-3727 in your dependencies?
Find it across Go, including transitive dependencies.