CVE-2024-37160 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in getformwork/formwork. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for getformwork/formwork — see the affected versions and patch details below.
Formwork has a Cross-site scripting (XSS) vulnerability in Description metadata
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-37160.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
getformwork/formwork🐘getformwork/formworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Regardless of the role or privileges, no user should be able to inject malicious JavaScript (JS) scripts into the body HTML. an XSS (Cross-Site Scripting) vulnerability, specifically a Stored XSS, which affects all pages of the website. Once the JS script is embedded in the body HTML, the XSS will trigger on any page a victim visits, such as the about, blog, contact, or any other pages, except for the panel.
Impact
This vulnerability allows attackers to inject malicious JS or HTML through a crafted payload into the vulnerable spot, achieving persistence and attacking numerous visitors or anyone accessing the website. The attack can be widespread and affect many users because the malicious JS will execute on every page, unlike an injection on a specific page (e.g., injecting on the About page would only affect that page). In this case, a single injection point leads to the execution of the malicious JS on all pages.
Patches
- Formwork 1.13.1 has been released with a patch that solves this vulnerability by escaping all metadata attributes.
- Formwork 2.x (f531201) also escapes metadata attributes.
Details
An attackers (requires administrator privilege) to execute arbitrary web scripts by modifying site options via /panel/options/site. This type of attack is suitable for persistence, affecting visitors across all pages (except the dashboard).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | getformwork/formwork | all versions | 1.13.1composer require getformwork/formwork:^1.13.1 |
| 🐘Packagist | getformwork/formwork | ≥ 2.0.0-beta.1&&< 2.0.0-beta.2 | 2.0.0-beta.2composer require getformwork/formwork:^2.0.0-beta.2 |
Affected Products
formworkformwork_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for getformwork/formwork, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update getformwork/formwork to 1.13.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-37160 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-37160 in your dependencies?
Find it across Packagist, including transitive dependencies.