CVE-2024-36404 is a critical-severity (CVSS 9.8) CWE-95 vulnerability in org.geotools:gt-app-schema. EPSS puts its 30-day exploitation probability at 76.1% (100th percentile). A fix is available for org.geotools:gt-app-schema — see the affected versions and patch details below.
GeoTools Remote Code Execution (RCE) vulnerability in evaluating XPath expressions
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-36404.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.geotools:gt-app-schema☕org.geotools:gt-complex☕org.geotools.xsd:gt-xsd-core☕org.geotools:gt-app-schema☕org.geotools:gt-complex☕org.geotools.xsd:gt-xsd-core☕org.geotools:gt-app-schema☕org.geotools:gt-complex+4 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Remote Code Execution (RCE) is possible if an application uses certain GeoTools functionality to evaluate XPath expressions supplied by user input.
Details
The following methods pass XPath expressions to the commons-jxpath library which can execute arbitrary code and would be a security issue if the XPath expressions are provided by user input.
org.geotools.appschema.util.XmlXpathUtilites.getXPathValues(NamespaceSupport, String, Document)org.geotools.appschema.util.XmlXpathUtilites.countXPathNodes(NamespaceSupport, String, Document)org.geotools.appschema.util.XmlXpathUtilites.getSingleXPathValue(NamespaceSupport, String, Document)org.geotools.data.complex.expression.FeaturePropertyAccessorFactory.FeaturePropertyAccessor.get(Object, String, Class<T>)org.geotools.data.complex.expression.FeaturePropertyAccessorFactory.FeaturePropertyAccessor.set(Object, String, Object, Class)org.geotools.data.complex.expression.MapPropertyAccessorFactory.new PropertyAccessor() {...}.get(Object, String, Class<T>)org.geotools.xsd.StreamingParser.StreamingParser(Configuration, InputStream, String)
PoC
The following inputs to StreamingParser will delay the response by five seconds:
new org.geotools.xsd.StreamingParser(
new org.geotools.filter.v1_0.OGCConfiguration(),
new java.io.ByteArrayInputStream("<Filter></Filter>".getBytes()),
"java.lang.Thread.sleep(5000)")
.parse();
Impact
This vulnerability can lead to executing arbitrary code.
Mitigation
GeoTools can operate with reduced functionality by removing the gt-complex jar from your application. As an example of the impact application schema datastore would not function without the ability to use XPath expressions to query complex content.
The SourceForge download page lists drop-in-replacement jars for GeoTools: 31.1, 30.3, 30.2, 29.2, 28.2, 27.5, 27.4, 26.7, 26.4, 25.2, 24.0. These jars are for download only and are not available from maven central, intended to quickly provide a fix to affected applications.
References
https://github.com/geoserver/geoserver/security/advisories/GHSA-6jj6-gm7p-fcvv https://osgeo-org.atlassian.net/browse/GEOT-7587 https://github.com/geotools/geotools/pull/4797 https://github.com/Warxim/CVE-2022-41852?tab=readme-ov-file#workaround-for-cve-2022-41852
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.geotools:gt-app-schema | ≥ 30.0&&< 30.4 | 30.4org.geotools:gt-app-schema:30.4 |
| ☕Maven | org.geotools:gt-complex | ≥ 30.0&&< 30.4 | 30.4org.geotools:gt-complex:30.4 |
| ☕Maven | org.geotools.xsd:gt-xsd-core | ≥ 30.0&&< 30.4 | 30.4org.geotools.xsd:gt-xsd-core:30.4 |
| ☕Maven | org.geotools:gt-app-schema | ≥ 31.0&&< 31.2 | 31.2org.geotools:gt-app-schema:31.2 |
| ☕Maven | org.geotools:gt-complex | ≥ 31.0&&< 31.2 | 31.2org.geotools:gt-complex:31.2 |
| ☕Maven | org.geotools.xsd:gt-xsd-core | ≥ 31.0&&< 31.2 | 31.2org.geotools.xsd:gt-xsd-core:31.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.geotools:gt-app-schema, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.geotools:gt-app-schema to 30.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-36404 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
How to detect CVE-2024-36404
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2024-36404 -u https://target- Template
- GeoServer and GeoTools - Remote Code Execution
- Severity
- critical
- Impact
- Unauthenticated attackers can execute arbitrary code remotely via XPath expression exploitation in GeoTools functionality.
- Remediation
- Update GeoServer and GeoTools to versions 31.2, 30.4, or 29.6 or later.
Template by ProjectDiscovery nuclei-templates (ritikchaddha, darses), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2024-36404 in your dependencies?
Find it across Maven, including transitive dependencies.