CVE-2024-32866 is a high-severity (CVSS 8.6) CWE-1321 vulnerability in @conform-to/dom. A fix is available for @conform-to/dom — see the affected versions and patch details below.
Conform contains Prototype Pollution Vulnerability in `parseWith...` function
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-32866.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@conform-to/domnpm@conform-to/zodnpm@conform-to/yupnpmDescription
Summary
Conform allows the parsing of nested objects in the form of object.property. Due to an improper implementation of this feature, an attacker can exploit it to trigger prototype pollution by passing a crafted input to parseWith... functions.
PoC
const { parseWithZod } = require('@conform-to/zod');
const { z } = require("zod");
const param = new URLSearchParams("__proto__.pollution=polluted");
const schema = z.object({ "a": z.string() });
parseWithZod(param, { schema });
console.log("pollution:", ({}).pollution); // should print "polluted"
Details
The invocation of the parseWithZod function in the above PoC triggers the setValue function through getSubmissionContext and parse, executing the following process, resulting in prototype pollution:
let pointer = value;
pointer.__proto__ = pointer.__proto__;
pointer = pointer.__proto__;
pointer.polluted = "polluted";
This is caused by the lack of object existence checking on line 117 in formdata.ts, where the code only checks for the presence of pointer[key] without proper validation.
Impact
Applications that use conform for server-side validation of form data or URL parameters are affected by this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @conform-to/dom | ≥ 1.0.0&&< 1.1.1 | 1.1.1npm install @conform-to/dom@1.1.1 |
| 📦npm | @conform-to/zod | ≥ 1.0.0&&< 1.1.1 | 1.1.1npm install @conform-to/zod@1.1.1 |
| 📦npm | @conform-to/yup | ≥ 1.0.0&&< 1.1.1 | 1.1.1npm install @conform-to/yup@1.1.1 |
| 📦npm | @conform-to/zod | all versions | 0.9.2npm install @conform-to/zod@0.9.2 |
| 📦npm | @conform-to/yup | all versions | 0.9.2npm install @conform-to/yup@0.9.2 |
| 📦npm | @conform-to/dom | all versions | 0.9.2npm install @conform-to/dom@0.9.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @conform-to/dom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @conform-to/dom to 1.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-32866 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-32866 in your dependencies?
Find it across npm, including transitive dependencies.