CVE-2024-32472 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in @excalidraw/excalidraw. A fix is available for @excalidraw/excalidraw — see the affected versions and patch details below.
excalidraw vulnerable to a Stored XSS in excalidraw's web embed component
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-32472.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@excalidraw/excalidrawnpmDescription
Summary
A stored XSS vulnerability in Excalidraw's web embeddable component. This allows arbitrary JavaScript to be run in the context of the domain where the editor is hosted.
Poc
Inserting an embed with the below url (can be copy/pasted onto canvas to insert as embed) will log 42 to the console:
https://gist.github.com/vv=v<script>console.log(42)</script>
Details
There were two vectors. One rendering untrusted string as iframe's srcdoc without properly sanitizing against HTML injection. Second by improperly sanitizing against attribute HTML injection. This in conjunction with allowing allow-same-origin sandbox flag (necessary for several embeds) resulted in the XSS.
Former was fixed by no longer rendering unsafe srcdoc content verbatim, and instead strictly parsing the supplied content and constructing the srcdoc manually. The latter by sanitizing properly.
The allow-same-origin flag is now also set only in cases that require it, following the principle of least privilege.
Impact
This is a cross site scripting vulnerability, for more information, please see: https://portswigger.net/web-security/cross-site-scripting
Two npm @excalidraw/excalidraw stable version releases were affected (0.16.x, 0.17.x), and both are now patched.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @excalidraw/excalidraw | ≥ 0.16.0&&< 0.16.4 | 0.16.4npm install @excalidraw/excalidraw@0.16.4 |
| 📦npm | @excalidraw/excalidraw | ≥ 0.17.0&&< 0.17.6 | 0.17.6npm install @excalidraw/excalidraw@0.17.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @excalidraw/excalidraw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @excalidraw/excalidraw to 0.16.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-32472 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-32472 in your dependencies?
Find it across npm, including transitive dependencies.