NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2024-31208 — matrix-synapse

MEDIUMFix: element-hq/synapse@55b0aa8

CVE-2024-31208 is a medium-severity (CVSS 6.5) CWE-770 vulnerability in matrix-synapse. A fix is available for matrix-synapse — see the affected versions and patch details below.

Synapse's V2 state resolution weakness allows DoS from remote room members

Also known asGHSA-3h7q-rfh9-xm4vPYSEC-2024-50
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-31208.

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.64%2.10%3.55%5.01%2.3%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍matrix-synapse

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

A remote Matrix user with malicious intent, sharing a room with Synapse instances before 1.105.1, can dispatch specially crafted events to exploit a weakness in how the auth chain cover index is calculated. This can induce high CPU consumption and accumulate excessive data in the database of such instances, resulting in a denial of service.

Servers in private federations, or those that do not federate, are not affected.

Patches

Server administrators should upgrade to 1.105.1 or later.

Workarounds

One can:

  • ban the malicious users or ACL block servers from the rooms; and/or
  • leave the room and purge the room using the admin API

For more information

If you have any questions or comments about this advisory, please email us at security AT element.io.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImatrix-synapseall versions1.105.1pip install --upgrade 'matrix-synapse==1.105.1'

Affected Products

2 products · 4 configurations
OS
fedorafedoraproject
3 versions
383940
Application
synapsematrix
< 1.105.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for matrix-synapse, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update matrix-synapse to 1.105.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-31208 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact A remote Matrix user with malicious intent, sharing a room with Synapse instances before 1.105.1, can dispatch specially crafted events to exploit a weakness in how the auth chain cover index is calculated. This can induce high CPU consumption and accumulate excessive data in the database of such instances, resulting in a denial of service. Servers in private federations, or those that do not federate, are not affected. ### Patches Server administrators should upgrade to 1.105.1 or later. ### Workarounds One can: - ban the malicious users or ACL block servers from the rooms; a
O3 Security · Impact-Aware SCA

Is CVE-2024-31208 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-31208: matrix-synapse DoS — Fixed in 1.105.1