CVE-2025-61672 — matrix-synapse
Fix: element-hq/synapse@26aaaf9CVE-2025-61672 is a CWE-1287 vulnerability in matrix-synapse. A fix is available for matrix-synapse — see the affected versions and patch details below.
Synapse: Invalid device keys degrade federation functionality
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-61672.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
matrix-synapse🐍matrix-synapseReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Lack of validation for device keys in Synapse before 1.138.3 and in Synapse 1.139.0 allow an attacker registered on the victim homeserver to degrade federation functionality, unpredictably breaking outbound federation to other homeservers.
Patches
Patched in Synapse 1.138.3, 1.138.4, 1.139.1, and 1.139.2.
Note that even though 1.138.3 and 1.139.1 fix the vulnerability, they inadvertently introduced an unrelated regression. For this reason, it is recommend to skip these releases and upgrading straight to 1.138.4 and 1.139.2.
Workarounds
The vulnerability can only be exploited by users registered on the victim homeserver.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | matrix-synapse | all versions | 1.138.3pip install --upgrade 'matrix-synapse==1.138.3' |
| 🐍PyPI | matrix-synapse | ≥ 1.139.0rc2&&< 1.139.1 | 1.139.1pip install --upgrade 'matrix-synapse==1.139.1' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for matrix-synapse, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update matrix-synapse to 1.138.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-61672 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-61672 in your dependencies?
Find it across PyPI, including transitive dependencies.