NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2024-3116 — pgadmin4

HIGHFix: pgadmin-org/pgadmin4@fbbbfe2

CVE-2024-3116 is a high-severity (CVSS 7.4) CWE-77 vulnerability in pgadmin4. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for pgadmin4 — see the affected versions and patch details below.

Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4

Also known asGHSA-27jx-ffw8-xrqvPYSEC-2026-1767
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-3116.

EPSS Exploitation Probability

via FIRST.org ↗
65.8%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
57.1%70.9%84.7%98.4%90.7%65.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pgadmin4

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

pgAdmin <= 8.4 is affected by a Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpgadmin4all versions8.5pip install --upgrade 'pgadmin4==8.5'

Affected Products

2 products · 2 configurations
OS
fedorafedoraproject
1 version
39
Application
pgadmin 4pgadmin
≤ 8.4
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pgadmin4, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pgadmin4 to 8.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-3116 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

pgAdmin <= 8.4 is affected by a Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.
O3 Security · Impact-Aware SCA

Is CVE-2024-3116 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-3116: pgadmin4 RCE — Fixed in 8.5