NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2024-29901 — @workos-inc/authkit-nextjs

MEDIUMFix: workos/authkit-nextjs@6c3f4f3

CVE-2024-29901 is a medium-severity (CVSS 4.8) CWE-294 vulnerability in @workos-inc/authkit-nextjs. A fix is available for @workos-inc/authkit-nextjs — see the affected versions and patch details below.

@workos-inc/authkit-nextjs session replay vulnerability

Also known asGHSA-35w3-6qhc-474v
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-29901.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.77%1.16%0.5%0.7%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

5other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@workos-inc/authkit-nextjsnpm
1.5Mdownloads / week

Description

The AuthKit library for Next.js provides helpers for authentication and session management using WorkOS & AuthKit with Next.js. A user can reuse an expired session by controlling the x-workos-session header. The vulnerability is patched in v0.4.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@workos-inc/authkit-nextjsall versions0.4.2npm install @workos-inc/authkit-nextjs@0.4.2

Affected Products

1 product · 1 configurations
Application
authkit-nextjsworkos
< 0.4.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @workos-inc/authkit-nextjs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @workos-inc/authkit-nextjs to 0.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-29901 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The AuthKit library for Next.js provides helpers for authentication and session management using WorkOS & AuthKit with Next.js. A user can reuse an expired session by controlling the `x-workos-session` header. The vulnerability is patched in v0.4.2.
O3 Security · Impact-Aware SCA

Is CVE-2024-29901 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-29901: @workos-inc/authkit — Fixed in 0.4.2